Categories
Security Windows 10 Windows 11

Security Advisory: Update PowerShell 7

Microsoft is advising system admins to update any systems that have PowerShell 7.0 or 7.1 installed due to another vulnerability that has been identified. Details on what the issues are can be found here and here. Versions 7.0.8 and 7.1.5 were released this past week that fix the two vulnerabilities.

Here is the downside: The current production release for PowerShell 7 is not supported by Windows Update so admins will need to download and deploy the patches through their on site processes. Rumor is that the next release, 7.2, may have support for Windows Update. Until then, happy patching!

References: https://www.bleepingcomputer.com/news/microsoft/microsoft-asks-admins-to-patch-powershell-to-fix-wdac-bypass/

Leave a Reply

%d bloggers like this: